aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Compilar amule con webserver en gentoo  (Read 3436 times)

batousay

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 3
Compilar amule con webserver en gentoo
« on: September 07, 2005, 11:25:39 AM »

Me he actualizado a la versión 2.0.3 haciendo un:
$ ACCEPT_KEYWORDS=~x86 emerge amule
con la anterior versión que tenia (la 2.0.1) cuando activaba el webserver no daba ningun fallo, pero en esta versión cuando re-inicio el amule me sale este error :

"quested to run webserver from startup, but the amuleweb binary cannot be run. Please install de package containing aMule webserver, or compile aMule using --enable-webserver an"(solo me sale en una línea y por eso se me corta al principio y al final)

he intentado emergerlo con:
$ ACCEPT_KEYWORDS=~x86 USE="--enable-webserver" emerge amule
pero naturalmente na de na.

¿Alguna idea de como hacerlo?


Por otra parte, siempre que inicio amule sea con el usuario que sea me sale el siguiente mensaje:
"Cannot set locale to 'es_ES'"
¿Tengo que darle permisos a alguna carpeta especial para que cambie la local?

[bye] Gracias por adelantado!!

Casi se me olvidaba... Uso Gentoo con kernel 2.6.11 y KDE 3.3.2
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Compilar amule con webserver en gentoo
« Reply #1 on: September 07, 2005, 12:57:14 PM »

prueba con --enable-amuleweb ;)

sobre la locale, prueba a ejecutar:
LC_ALL=es_ES amule

a ver si asi te lo pilla en castellano.

un saludo!
Logged

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
RE: Compilar amule con webserver en gentoo
« Reply #2 on: September 07, 2005, 12:57:56 PM »

Quote
Originally posted by batousay
Me he actualizado a la versión 2.0.3 haciendo un:
$ ACCEPT_KEYWORDS=~x86 emerge amule
con la anterior versión que tenia (la 2.0.1) cuando activaba el webserver no daba ningun fallo, pero en esta versión cuando re-inicio el amule me sale este error :

"quested to run webserver from startup, but the amuleweb binary cannot be run. Please install de package containing aMule webserver, or compile aMule using --enable-webserver an"(solo me sale en una línea y por eso se me corta al principio y al final)

A mi esto en FreeBSD tb me pasa, con la misma versión. Tengo que lanzar el webserver a mano, porque estar está.
Logged
First of all, I apologize for my bad english. :D

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: Compilar amule con webserver en gentoo
« Reply #3 on: September 07, 2005, 01:06:37 PM »

USE="remote" emerge -Dav amule


no

USE="--enable-webserver"

!!
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."