aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: does not want to open  (Read 2091 times)

avrock

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
    • http://meteo media
does not want to open
« on: November 20, 2005, 08:17:40 PM »

hi, when I try running aMule, it refuses to open.
In the shell, it is what there is of writing.
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------Current version is: aMule 2.0.0 using wxGTK1 v2.4.2
Running on: Linux 2.6.9-1.649.radeon i686

[2] wxFatalSignalHandler in /usr/lib/libwx_gtk-2.4.so.0[0x3fc329d]
[3] ?? in [0xb7f1a420]

--------------------------------------------------------------------------------Abandon
and when I try to debug amule with the gdb, it write this:
(gdb) run
Starting program: /usr/bin/amule
Reading symbols from shared object read from target memory...(no debugging symbols found)...done.
Loaded system supplied DSO at 0xb7f30000
(no debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread -1208923808 (LWP 4518)]
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...Initialising aMule
Checking if there is an instance already running...

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208923808 (LWP 4518)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x03ec1d74 in wxItemContainer::Append () from /usr/lib/libwx_gtk-2.4.so.0
#2  0x0827cda0 in CSearchDlg::UpdateCatChoice ()
#3  0x0819238b in CamuleDlg::CamuleDlg ()
#4  0x0818c844 in CamuleGuiBase::InitGui ()
#5  0x0818c972 in CamuleGuiApp::InitGui ()
#6  0x081882da in CamuleApp::OnInit ()
#7  0x0818caaf in CamuleGuiApp::OnInit ()
#8  0x03e59210 in wxEntry () from /usr/lib/libwx_gtk-2.4.so.0
#9  0x0818c65b in main ()
(gdb) bt full
#0  0x00000000 in ?? ()
No symbol table info available.
#1  0x03ec1d74 in wxItemContainer::Append () from /usr/lib/libwx_gtk-2.4.so.0
No symbol table info available.
#2  0x0827cda0 in CSearchDlg::UpdateCatChoice ()
No symbol table info available.
#3  0x0819238b in CamuleDlg::CamuleDlg ()
No symbol table info available.
#4  0x0818c844 in CamuleGuiBase::InitGui ()
No symbol table info available.
#5  0x0818c972 in CamuleGuiApp::InitGui ()
No symbol table info available.
#6  0x081882da in CamuleApp::OnInit ()
No symbol table info available.
#7  0x0818caaf in CamuleGuiApp::OnInit ()
No symbol table info available.
#8  0x03e59210 in wxEntry () from /usr/lib/libwx_gtk-2.4.so.0
No symbol table info available.
#9  0x0818c65b in main ()
No symbol table info available.
(gdb) thread apply all bt

Thread 1 (Thread -1208923808 (LWP 4518)):
#0  0x00000000 in ?? ()
#1  0x03ec1d74 in wxItemContainer::Append () from /usr/lib/libwx_gtk-2.4.so.0
#2  0x0827cda0 in CSearchDlg::UpdateCatChoice ()
#3  0x0819238b in CamuleDlg::CamuleDlg ()
#4  0x0818c844 in CamuleGuiBase::InitGui ()
#5  0x0818c972 in CamuleGuiApp::InitGui ()
#6  0x081882da in CamuleApp::OnInit ()
#7  0x0818caaf in CamuleGuiApp::OnInit ()
#8  0x03e59210 in wxEntry () from /usr/lib/libwx_gtk-2.4.so.0
#9  0x0818c65b in main ()
(gdb)
And amule don't works again, I installed amule with rpms, before it runing very well, what can I do now for to fix the bug?
tanks
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: does not want to open
« Reply #1 on: November 20, 2005, 09:12:57 PM »

did you update your wxGTK rpms mayb?
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

avrock

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
    • http://meteo media
Re: does not want to open
« Reply #2 on: November 21, 2005, 06:05:07 PM »

that does not funtion, I tested update and upgrade with yum: libwx_gtk-2, gtk-2 and aMule,
and it write this ' no packages marked for Update/obsoletion'.
two week ago, I ugrade all fedora with yum,
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: does not want to open
« Reply #3 on: November 21, 2005, 06:22:22 PM »

^^
problem is, if oyu use wxGTK from fedora, but the aMule-rpms from us,

they are incompatible with each other.

so maybe remove wxGTK from fedora and take the one from our download page
see if it does any better
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."