aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: emule port on freebsd  (Read 6474 times)

boris

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
emule port on freebsd
« on: November 23, 2005, 11:34:55 PM »

I've installed amule on a freebsd 6.0 box through the ports collection (/net/amule2) make, make install. Installation completed with no errors. (just took me 2 ours on a 1.7ghz, X11 anyone?)
I feel sorry to ask the stupid question but can I just start it from the command line? I didn't select the given option to install amule as a deamon, how do I reconfigure it to be so?
As you must know I'am a freebsd newbie.

Thanx for your help
Logged

lfroen

  • Guest
Re: emule port on freebsd
« Reply #1 on: November 24, 2005, 06:58:30 AM »

amule is GUI app, amuled is daemon, which is started from command line by typing "amuled"
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: emule port on freebsd
« Reply #2 on: November 24, 2005, 07:45:27 AM »

http://www.amule.org/wiki/index.php/HowTo_Compile_aMuled

this is hte guide for amuled, and all the configure flags you need
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Re: emule port on freebsd
« Reply #3 on: November 24, 2005, 08:59:01 AM »

Easy ;)

"make config" before make on amule2 directory, and select amuled option, or "make WITH_AMULEDAEMON=yes install"

Then you have to add to your /etc/rc.conf this: "amuled_enable=YES" and "amuled_user="
Logged
First of all, I apologize for my bad english. :D

boris

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: emule port on freebsd
« Reply #4 on: November 25, 2005, 10:13:36 PM »

Okay, thanks guys.

When I tried to start amuled i got the following output:
Quote
amuled: OnInit - starting timer
Initialising aMule
Checking if there is an instance already running...
Loading temp files from /usr/home/borisb/temp.

All PartFiles Loaded.
ListenSocket: Ok.

*** TCP socket (ECServer) listening on 0.0.0.0:4711
*** Server UDP socket (TCP+3) at 0.0.0.0:4665
*** TCP socket (TCP) listening on 0.0.0.0:4662
*** Client UDP socket (extended eMule) at 0.0.0.0:4672
Empty dir /usr/home/borisb/incoming/ shared
General: CamuleDaemonApp::OnRun()

I want to control my deamon useing amuleweb.

Included my configuration files
« Last Edit: November 25, 2005, 10:14:49 PM by boris »
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: emule port on freebsd
« Reply #5 on: November 26, 2005, 08:35:12 AM »

ok

one error:

in the remote.conf teh

EC-port has to be the SAME as in amule.conf!! otherwise it would not connect


ok and now 2things you can do:

1st.
if you enable webserver in amule.conf file, amuled would try! to start amuleweb right after itself, so it would search in your $PATH variable and try to start it.
if this succedes everything is fine and you can use amuleweb right away after deamon start.

2nd.
you start amuleweb yourself.
so you leave amule.conf as is, and start amuleweb manually whenever you want. for this you would have to fix
remote.conf tho

hope that helps :))
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

boris

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: emule port on freebsd
« Reply #6 on: November 26, 2005, 09:08:30 PM »

Okay, set the [WebServer] -> Enabled=1 in the amule.conf file.

When I start amuled I still get this:

*** TCP socket (ECServer) listening on 0.0.0.0:4711
*** Server UDP socket (TCP+3) at 0.0.0.0:4665
*** TCP socket (TCP) listening on 0.0.0.0:4662
*** Client UDP socket (extended eMule) at 0.0.0.0:4672
Empty dir /usr/home/borisb/incoming/ shared
General: CamuleDaemonApp::OnRun()

After the last line it hangs up and I can only continue pressing .

Shutdown requested, terminating in next event loop.Now, exiting main app...
Killing amuleweb instance...
Killed!

While the deamon is running I can't even go to the website, page unreachable internet explorer says on port 4711.


Why is my amule listening to 0.0.0.0? I've two network interfaces in my freebsd box, how do I tell amule to listen on both or a specific device?
« Last Edit: November 26, 2005, 09:36:25 PM by boris »
Logged

lfroen

  • Guest
Re: emule port on freebsd
« Reply #7 on: November 26, 2005, 09:14:00 PM »

Quote
While the deamon is running I can't even go to the website, page unreachable internet explorer says on port 4711

daemon (amuled) is amule core, which need another program, called amuleweb to create web pages.

Quote
Why is my amule listening to 0.0.0.0
That's a way it is designed.
Logged

boris

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: emule port on freebsd
« Reply #8 on: November 26, 2005, 09:42:22 PM »

daemon (amuled) is amule core, which need another program, called amuleweb to create web pages.

The manual says
Shutdown aMuled if it is still running.
Run amuleweb -w to generate ~/.aMule/remote.conf and edit it for these options. It previously were on ~/.aMule/amule.conf, but the lines are still on this file, so edit both if in doubt.
[ExternalConnect] <- Section header
AcceptExternalConnections=1 <-- To enable aMule listening for External Connections.
ECUseTCPPort=1 <-- To use the TCP port. Very important since Unix sockets are disabled.
ECPassword=ca3c365274907c6fd527068788e14639 <-- To find the MD5 string for your password, do:
$ echo -n yourpasswordhere | md5sum | cut -d ' ' -f 1
ca3c365274907c6fd527068788e14639

Restart aMuled


There is nothing written about starting any other deamon than amule itself

Why is my amule listening to 0.0.0.0
That's a way it is designed.

Ah, I asked a stupid question. You've made yourself completely clear. :P

edit:
Oh, still don't know why I don't get my $ or # back after starting up the deamon.
« Last Edit: November 26, 2005, 09:43:37 PM by boris »
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: emule port on freebsd
« Reply #9 on: November 26, 2005, 10:20:03 PM »

add a & behind it

start the daemon like

amuled &

or (which does not work really good sometimes)

amuled -f

btw: there is a --help command ;)


about amuleweb, if you enable it in amule.conf you should have two processes running

one amuled and one amuleweb

or you start amuleweb yourself afterwards, for this to work use

amuleweb -q & (-q for quite, and & for sending to background)

--help works also for amuleweb :)
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

boris

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: emule port on freebsd
« Reply #10 on: November 26, 2005, 11:38:58 PM »

Thanks for the &, didn't know that (new user to unix). Next problem (you guys must get annoyed by this stupid-don't-know-anything-user by now)

amuleweb -p4711 -v
looking for template: default
checking for directory '/root/.aMule/webserver'... no
checking for directory '/usr/X11R6/share/gnome/amule/webserver'... yes
checking for directory '/usr/X11R6/share/gnome/amule/webserver/default'... yes
checking for file '/usr/X11R6/share/gnome/amule/webserver/default/aMule.tmpl'... yes
*** Using template: /usr/X11R6/share/gnome/amule/webserver/default/aMule.tmpl

Creating client...
Now, doing connection....
Using host 'localhost' port: 4711
Trying to connect (timeout = 10 sec)...
Succeeded! Connection established to aMule 2.0.3

---------------------------------
|       aMule Web Server        |
---------------------------------


Use 'Help' for command list

Web Server: Started
aMuleweb$
WSThread: Thread started
WSThread: created service
WSThread: could not create socket on :4711
aMuleweb$

Still can't connect to port 4711 useing an internet browser. What does the message "could not create socket" mean? The help command isn't very useful:

----------------> Help: Available commands (case insensitive): <----------------

Help:                   Shows this help.
Quit, Exit:             Exits aMuleWeb.

----------------------------> End of listing <----------------------------------

Just two commands I could invent myself.
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: emule port on freebsd
« Reply #11 on: November 27, 2005, 01:10:12 AM »

could not create socket means, tehre is something running at this port already...
maybe try another port and see if that works (but the webserver port NOT the EC-port)

of course when the socket is not createt you cannot connect with firefox...
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Re: emule port on freebsd
« Reply #12 on: November 27, 2005, 06:50:58 PM »

In FreeBSD don't start amuled with &. Just add to /etc/rc.conf those lines:
amuled_enable="YES"
amuled_user=""

and type this: /usr/local/etc/rc.d/amuled.sh start

If you need to stop amuled just type: /usr/local/etc/rc.d/amuled.sh stop

And when you turn on your computer, amuled will start automatically.
Logged
First of all, I apologize for my bad english. :D