aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: forum for known wxwidgets problems ?  (Read 3033 times)

Arichy

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 224
forum for known wxwidgets problems ?
« on: January 13, 2006, 09:01:37 AM »

It seems, that there are some problems with wxwidgets/wxgtk that effect amule in the way that it crashes. E.G. if wxgtk is not compiled the right way or patched.

To concentrate the known problems for the binary package maintainers and also the users who want to compile wxgtk/amule for their own, maybe there should be an extra forum for known wxgtk problems and howtos? The Wiki seems not very updated.

Greets, Arichy

EDIT: With forum I mean a category (board?) in this forum ;)
« Last Edit: January 13, 2006, 09:04:13 AM by Arichy »
Logged
Gentoo i686

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: forum for known wxwidgets problems ?
« Reply #1 on: January 13, 2006, 09:42:20 AM »

Maybe a sticky thread is enough.

I propose to replace this sticky thread:

http://forum.amule.org/thread.php?threadid=5356

Because it's more or less the same topic, but the information has changed over the time (e.g. wxWidgets 2.5 is no longer supported anyway, instead we have the buggy 2.6.2 etc.)

Just for brainstorming - this information might be relevant so far:

- wxWidgets >= 2.6.0 is needed (clear), but the latest is recommended.

- Do not enable STL in wxWidgets at the moment. It's untested.

- If you want to use wxWidgets 2.6.2, you must:

  * either apply this patch to the wxWidgets source:

http://cvs.wxwidgets.org/viewcvs.cgi/wxWidgets/src/common/intl.cpp.diff?r1=1.166&r2=1.166.2.1&diff_format=u

  * or disable NLS support in aMule (worse solution for obvious reasons).

- This patch might be useful for wxWidgets =< 2.6.2 to prevent some crashes:

http://cvs.wxwidgets.org/viewcvs.cgi/wxWidgets/src/unix/gsocket.cpp.diff?r1=1.51&r2=1.51.2.1&diff_format=u

- You must use compatible compilers for wxWidgets and aMule. GCC 3.2 and 3.3 are compatible among each other and GCC 3.4 and 4.0 are compatible among each other. Other variants are _not_ compatible. You cannot, let's say, use GCC 3.3 for wxWidgets and GCC 3.4 for aMule - there _will_ be errors at runtime.

(yes, this is a frequently asked question)

- If you find unsuitable binary wxWidgets packages on the web or maybe even in your distro repository, the easiest solution is to create and distribute fixed ones. Feel free to do that, but in addition please consider reporting the problems as bugs to the original maintainers so they can fix it, too.

- If you want to use the latest and greatest wxWidgets, you can do a CVS checkout as described here:

http://wxwidgets.org/cvs.htm

Please read the instructions completely, especially the "wxWidgets Modules" part. The information in that part can save you a lot of bandwidth, time and disk space.

Alternatively, there are pre-packaged wxWidgets CVS tarballs here:

http://biolpc22.york.ac.uk/pub/CVS_HEAD/

Some people might find them easier to use. Linux users should download the "gtk" tarball, not the "all" tarball. The "gtk" tarball is smaller and absolutely sufficient - save York University's bandwidth.

To be continued...
Logged