aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Crash kurz nach dem starten  (Read 4175 times)

Cold

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 41
Crash kurz nach dem starten
« on: February 04, 2006, 11:40:27 PM »

ich hab mir amule nach dem howto in der wiki selbst kompiliert (auch wxGTK-2.6.2) hab alles so gemacht wies da steht und nun kommt kurz nach dem start die meldung (in der konsole)

--------------------------------------------------------------------------------A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/board.php?boardid=67
If possible, please try to generate a real backtrace of this crash:
    http://www.amule.org/wiki/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------Current version is: aMule 2.1.0 using wxGTK2 v2.6.2 (Unicoded)
Running on: Linux 2.6.15-1.1830_FC4 i686

[2] CamuleApp::OnFatalException() in :0
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.6.so.0[0x410e4e0e]
[4] ?? in [0x166420]
[5] ?? in [0x9f10be1]
[6] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x41428800]
[7] ?? in /usr/lib/libglib-2.0.so.0 [0x41ac64fc]
[8] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0x41aa04ce]
[9] ?? in /usr/lib/libglib-2.0.so.0 [0x41aa34d6]
[10] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x41aa37c3]
[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x8cca46]
[12] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0x50026f]
[13] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0x57cb84]
[14] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0x57cc6a]
[15] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.6.so.0[0x4108f563]
[16] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.6.so.0[0x4108f631]
[17] main in :0
[18] __libc_start_main in /lib/libc.so.6[0x4184ed5f]
[19] __gxx_personality_v0 in :0


--------------------------------------------------------------------------------Abgebrochen

gibts irgendwelche patches daführ?
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
Re: Crash kurz nach dem starten
« Reply #1 on: February 05, 2006, 12:04:00 AM »

Variante 1 (workaround): In der amule.conf die Sprache auf en_US stellen.
Variante 2: wxGTK 2.6.2. patchen und neu kompilieren (Patch: http://cvs.wxwidgets.org/viewcvs.cgi/wxWidgets/src/unix/gsocket.cpp.diff?r1=1.51&r2=1.51.2.1&diff_format=u)
Logged

Cold

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 41
Re: Crash kurz nach dem starten
« Reply #2 on: February 05, 2006, 12:30:58 AM »

tja, ich hab die variante 3 gewählt "einfach die cvs-version installieren  8) "
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
Re: Crash kurz nach dem starten
« Reply #3 on: February 05, 2006, 09:54:15 AM »

;) OK, das geht natürlich auch, aber da es in letzter Zeit ein paar Problemchen mit der CVS gab (sowohl der aMule CVS als auch der wxCVS) würde ich diese im Moment wirklich nur zum Testen verwenden, wenn man die Entwicklung durch Fehlerreporte unterstützen will.
Wenn es aber wieder gut läuft (im Bezug auf die wxCVS), dann könnte ich ja auch mal ein Upgrade wagen...;)
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: Crash kurz nach dem starten
« Reply #4 on: February 05, 2006, 10:08:47 AM »

wxcvs is ok.....die sind grad kurz vor 2.6.3 alles kein problem
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."