aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: crash at start up  (Read 2005 times)

Bourdieu

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 55
crash at start up
« on: March 19, 2006, 04:04:09 PM »

Here is the report I get:

Code: [Select]
Initialising aMule
Checking if there is an instance already running...
No other instances are running.
HTTP download thread started
Loading temp files from /home/mathieu/.aMule/Temp.

All PartFiles Loaded.
ListenSocket: Ok.

*** TCP socket (ECServer) listening on 0.0.0.0:4712
*** Server UDP socket (TCP+3) at 0.0.0.0:14665
*** TCP socket (TCP) listening on 0.0.0.0:14662
*** Client UDP socket (extended eMule) at 0.0.0.0:14672
HTTP download thread started
Host: amule.sourceforge.net:80
URL: [URL]http://amule.sourceforge.net/lastversion[/URL]
Response: 200 (Error: 0)
Download size: 7
HTTP download thread ended
Host: [URL]www.bluetack.co.uk:80[/URL]
URL: [URL]http://www.bluetack.co.uk/config/ipfilter.dat[/URL]
Response: 301 (Error: 0)

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    [URL]http://forum.amule.org/board.php?boardid=67[/URL]
If possible, please try to generate a real backtrace of this crash:
    [URL]http://www.amule.org/wiki/index.php/Backtraces[/URL]

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.1.1 using wxGTK2 v2.6.2
Running on: Linux 2.6.15.6 i686

[2] ?? in amule [0x8070b56]
[3] wxFatalSignalHandler in /usr/lib/libwx_base-2.6.so.0[0xb7a65c26]
[4] ?? in [0xffffe420]
[5] ?? in [0x9028d31]
[6] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0xb740cf2b]
[7] ?? in /usr/lib/libglib-2.0.so.0 [0xb731553f]
[8] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0xb72edb77]
[9] ?? in /usr/lib/libglib-2.0.so.0 [0xb72ef505]
[10] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0xb72ef82a]
[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0xb759eac3]
[12] wxEventLoop::Run() in /usr/lib/libwx_gtk2_core-2.6.so.0[0xb7bbed05]
[13] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2_core-2.6.so.0[0xb7c432e9]
[14] wxAppBase::OnRun() in /usr/lib/libwx_gtk2_core-2.6.so.0[0xb7c43463]
[15] wxEntry(int&, char**) in /usr/lib/libwx_base-2.6.so.0[0xb7a09a00]
[16] ?? in amule [0x818d7ee]
[17] __libc_start_main in /lib/tls/libc.so.6[0xb7780e14]
[18] wxAppBase::Dispatch() in amule[0x8068e01]


--------------------------------------------------------------------------------
Abandon
Logged

Bourdieu

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 55
Re: crash at start up
« Reply #1 on: March 19, 2006, 05:04:42 PM »

Indeed wxWidgets-2.6.3-rc3 fix the problem.
Logged

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: crash at start up
« Reply #2 on: March 19, 2006, 06:15:50 PM »

rc3? You mean rc1 or rc2. ;)

rc2 is already announced at wxwidgets.org, but not yet hyperlinked at the dowloads page. Grab it from here:

http://biolpc22.york.ac.uk/pub/2.6.3-rc2/
Logged

Bourdieu

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 55
Re: crash at start up
« Reply #3 on: March 19, 2006, 07:35:52 PM »

Yes sorry, I meant rc2 which I found the link here:

http://www.wxwidgets.org/downld2.htm
Logged