aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: problème de lancement  (Read 11349 times)

Le_PoUnT

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
problème de lancement
« on: March 21, 2006, 09:38:27 PM »

slt, tout d'abord bravo à la team vous faîtes un énorme boulot :baby: (et dans un sens j'espère que vous n'êtes pas français, à cause de ce put.... ain d'amendement Vivendi Universal/Sacem/et_tous_les_autres )

Bon voilà mon souci:

J'étais jusqu'à il y a peu en 2.1.0-1, lorsque la maj est sortie, je l'ai installé, mais il y avait à ce moment là un soucis de lib(libwx base2.6 et gkt2.6), donc j'ai prit mon mal en patience... en essayant mldonkey... mauvaise idée, on revient sur amule.

Maintenant que les librairies sont réparées, c'est une erreur au niveau Packages, qui me bloquait(erreur de taille). Facile à contourner en faisant une install manuelle en installant à la mano les deb.

Au moment du lancement de amule(via le menu kde), j'ai remarqué que c'était assez long donc je l'ais lancé via une console et ce message s'affiche:

Quote
amule: error while loading shared libraries: libbfd-2.15.so: cannot open shared object file: No such file or directory

J'ai cherché sur le forum, et j'ai trouvé cette solution, malheureusement pour moi... le fichier bfd.h n'existe pas, donc je me trouve bloqué.

je pensais qu'il suffisait d'installer cette librairie, mais apt-cache search, me donne comme solution binutils-dev et sont installation ne résoud pas le problème.

voilà si quelqu'un sait d'où vient le problème, je l'en remercie.
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
Re: problème de lancement
« Reply #1 on: March 21, 2006, 09:56:42 PM »

Salut!

Essaye de faire un symlink de ta nouveau version de libbfd.
Peut-etre est le nom de ta bibliotheque (library) different, execute ls /usr/lib | grep bfd dans un terminal pour savoir le nom. Remplacer le 'libbfd-2.16.so' avec ta bibliotheque.
Code: [Select]
cd /usr/lib
su
ln -s libbfd-2.16.so libbfd-2.15.so

J'espere que j'ai pu aider.

Edit: Mon francais est de plus en plus influence par des autres langues...:(
« Last Edit: March 21, 2006, 10:15:31 PM by wuischke »
Logged

Le_PoUnT

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: problème de lancement
« Reply #2 on: March 21, 2006, 10:04:22 PM »

bon autant pour moi, j'ai trouve la solution:
http://www.amule.org/wiki/index.php/HowTo_Compile_In_Debian

je suis en sid et ca ne marche que pour les versions stable...
Mais l'adresse pour la version etch(faute de mieux) ne marche pas...

Je sais pas pourquoi, je vais regretter de l'avoir fait cette maj, car je risque de pas etre pret a  pouvoir reinstaller amule avant un bye  ;(

Edit: merci wuisch, ca remarche, j'avais pas pense du tout a  creer un lien. :)) Encore merci.

Et t'inquietes pas... regarde moi j'essaye de pas faire de fautes, mais les accents sont pas acceptes... et on comprend rien a ce que je dis. on te lis plus facilement toi que moi. :D
« Last Edit: March 21, 2006, 10:19:44 PM by Le_PoUnT »
Logged

Le_PoUnT

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: problème de lancement
« Reply #3 on: March 21, 2006, 10:15:57 PM »

quand c'est pas fini, y'en a encore, voilà  ce qui s'affiche en mode console:

Error while getting vector size for backtrace symbols : Opération invalide[2] ?? in amule [0x807631f]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.6.so.0[0xb79d3278]
[4] ?? in [0xffffe420]
[5] ?? in /lib/tls/libc.so.6 [0xb77bb903]
[6] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0xb7327f9e]
[7] ?? in /usr/lib/libglib-2.0.so.0 [0xb72144bf]
[8] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0xb71eb11c]
[9] ?? in /usr/lib/libglib-2.0.so.0 [0xb71ee5ab]
[10] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0xb71ee907]
[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0xb74bb261]
[12] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0xb7bafe88]
[13] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0xb7c45073]
[14] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0xb7c451da]
[15] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.6.so.0[0xb796201e]
[16] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.6.so.0[0xb796211d]
[17] ?? in amule [0x815685c]
[18] __libc_start_main in /lib/tls/libc.so.6[0xb769aeb0]
[19] ?? in amule [0x806afa1]


La  par contre je dois avouer que c'est du charabia pour moi, mais je devine que les erreurs viennent des libwxbase et libwxgtk qui ont pourtant ete recuperees, ici:
http://amule-debian.dyndns.org/debian/wxgtk/
« Last Edit: March 21, 2006, 10:19:07 PM by Le_PoUnT »
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
Re: problème de lancement
« Reply #4 on: March 21, 2006, 10:34:49 PM »

Je pense que c'est le 'bug unicode' de wxGTK 2.6.2.
Ouvrie le fichier ~/.aMule/amule.conf et change 'Language=' de 'Language=en_US'. Apres aMule est en Anglais, mais cette un faute de wx.
Il y'a un patch pour cette bug, mais tu dois compiler ou trouver un bon paquete.
Logged

Le_PoUnT

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: problème de lancement
« Reply #5 on: March 22, 2006, 12:41:05 AM »

j'ai essaye d'alieniser ce paquet, mais ca ne marche pas car quand j'installe amule, j'ai ce message:

Quote
dpkg : des problemes de dependances empechent la configuration de amule :
 amule depend de libwxgtk2.6 ; cependant :
  Paquet libwxgtk2.6 n'est pas installe.
dpkg : erreur de traitement de amule (--install) :
 problemes de dependances - laisse non configure

Je n'ai pas trouve de patch pour debian deja  compile.

Je vais essayer avec une vesion CVS(quand ca sera fini de se dl... dans... 2H a peu pres  :rolleyes: ). Merci pour ton aide.
« Last Edit: March 22, 2006, 12:44:31 AM by Le_PoUnT »
Logged

Le_PoUnT

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: problème de lancement
« Reply #6 on: March 22, 2006, 04:51:18 PM »

meme en utilisant les derniers cvs, ça plante. il resterait comme solution a passer par amuleweb, mais je n'ai pas le temps de configurer amule, pour lui dire d'utiliser l'interface web que ça plante.

Si quelqu'un a le package deb du patch pour wxgtk, ça serait pus simple.

J'ai essaye de compiler a la mano, wxgtk, mais il me demande de recompiler aussi gtk+-2.8.16(ainsi que tout ses packages). Ca fait un peu beaucoup, d'un coup,
Logged

OldFrog

  • Sr. Member
  • ****
  • Karma: 31
  • Offline Offline
  • Posts: 386
Re: problème de lancement
« Reply #7 on: March 22, 2006, 08:46:57 PM »

Salut le catalan. tu vas dans le même répertoire où tu as pris le paquetage rpm wxGtk, tu prends le bz2 de wxGtk qui m'a servi pour le pondre, je viens de l'y remonter, et tu le compiles chez toi. Evidemment faudra que tu compiles aussi ta mule dessus.

Sinon, tu fais un alien aussi sur le rpm d'amule 2.1.1 qui est là aussi, il a été bâti avec, donc tu ne devrais pas avoir de problème.
« Last Edit: March 22, 2006, 08:48:25 PM by OldFrog »
Logged
Computer Science is no more about computers than astronomy is about telescopes (Edsger W. Dijkstra)

Le_PoUnT

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: problème de lancement
« Reply #8 on: March 23, 2006, 03:53:02 AM »

tient une vieille grenouille :))  ça fait un bail que je t'ai plus vu!

J'etais pas sur quand j'ai vu le nom de domaine que ce soit toi, mais j'ai eût un gros doute

Je n'ai pas trouve le bz2, là où t l'indiques, sur la racine on voit qu'il y a bien eut une modification, mais le fichier n'apparait pas(ajout suivi d'une suppresion?)
Logged

Le_PoUnT

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: problème de lancement
« Reply #9 on: March 23, 2006, 06:41:38 PM »

en attendant que Old Frog remette le bz2 sur son serveur j'ai cherché et ais fini par trouvé un package wxgtk avecl'unicode... malheureusement ça plante toujours, donc le problème n'a pas l'air de venir de l'unicode:

Quote
Current version is: aMule 2.1.0 using wxGTK2 v2.6.1 (Unicoded)
Running on: Linux 2.6.15.2-lepount i686

[2] wxThreadHelperThread::~wxThreadHelperThread() in amule [0x808135f]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.6.so.0[0xb769dfc6]
[4] ?? in [0xffffe420]
[5] ?? in /usr/lib/libwx_gtk2u_core-2.6.so.0 [0xb781e516]
[6] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0xb7029f9e]
[7] ?? in /usr/lib/libglib-2.0.so.0 [0xb6ef14bf]
[8] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0xb6ec811c]
[9] ?? in /usr/lib/libglib-2.0.so.0 [0xb6ecb5ab]
[10] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0xb6ecb907]
[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0xb71bd261]
[12] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0xb781c86e]
[13] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0xb78ae7f8]
[14] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.6.so.0[0xb78ae912]
[15] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.6.so.0[0xb764151b]
[16] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.6.so.0[0xb76415ee]
[17] CryptoPP::IteratedHashBase2, CryptoPP::HashTransformation>::~IteratedHashBase2() in amule [0x812c56e]
[18] __libc_start_main in /lib/tls/libc.so.6[0xb739ceb0]
[19] __gxx_personality_v0 in amule[0x807db21]


voilà les paquets installés:

Quote
apt-cache show libwxgtk2.6-0
Package: libwxgtk2.6-0
Priority: optional
Section: libs
Installed-Size: 8756
Maintainer: Ron Lee
Architecture: i386
Source: wxwidgets2.6
Version: 2.6.1.2

Quote
apt-get install amule=2.1.0-3 amule-common=2.1.0-3 libwxgtk2.6-0

j'ai bien fait attention à vérifier les packages en les sélectionnant via apt-get -s install mais ça n'a rien changé  ;(

Bon ben Old Frog, tu es ma dernière chance :baby: lol
Logged

OldFrog

  • Sr. Member
  • ****
  • Karma: 31
  • Offline Offline
  • Posts: 386
Re: problème de lancement
« Reply #10 on: March 23, 2006, 08:38:57 PM »

Désolé, j'avais oublié que j'avais mis un filtre dans le php. Le lien        est ici.
Un fois installé, compile la mule 2.1.1, tout devrait fonctionner.

Ceci dit, pourquoi tu ne tentes pas la manip alien sur le rpm d'aMule après wxGtk ?
Logged
Computer Science is no more about computers than astronomy is about telescopes (Edsger W. Dijkstra)

OldFrog

  • Sr. Member
  • ****
  • Karma: 31
  • Offline Offline
  • Posts: 386
Re: problème de lancement
« Reply #11 on: March 23, 2006, 08:43:10 PM »

Options pour le configure de wxGtk
Code: [Select]
./configure
                --with-gtk=2 \
                --enable-largefile   \
                --disable-stl \
                --enable-unicode

Et pour la mule

Code: [Select]
./configure               \
        --prefix=%{_prefix} \
        --enable-cas \
        --enable-wxcas \
        --enable-amulecmd \
        --enable-amule-gui \
        --enable-webserver \
        --enable-webservergui \
        --enable-ccache \
        --enable-kad-compile \
        --enable-amulecmdgui \
        --enable-amule-daemon \
        --enable-embedded_crypto \
        --enable-monolithic \
        --enable-ed2k \
        --enable-alc \
        --enable-alcc \
        --enable-systray \

Comme ça tu auras la totale
Logged
Computer Science is no more about computers than astronomy is about telescopes (Edsger W. Dijkstra)

Le_PoUnT

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: problème de lancement
« Reply #12 on: March 23, 2006, 11:33:45 PM »

En fait le problème ne change rien. Pour compîler wxgtk ça me demande de compiler aussi gtk+ 2, comme dit plus haut dans le topic, je suppose que celà vient du fait que je sois en unstable.

J'ai essayé de le compiler aussi mais ça m'a demander de devoir compiler aussi toutes les dépendances(cairo, pango, atk.....), donc en clair de réinstaller tout le système à la limite, car si je change ça, ça va entraîner des problèmes de dépendances vis à vis d'autres package.

Je crois que le plus simple serait encore de formater, et de rester en stable maintenant.

Quitte à voillà le message d'erreur:

Quote
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.


j'ai déjà installé pkg-config, il ne reste donc que l'autre qui est demandé, mais pour ça... il me faut réinstaller gtk+2. Crying
« Last Edit: March 23, 2006, 11:43:16 PM by Le_PoUnT »
Logged

Le_PoUnT

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: problème de lancement
« Reply #13 on: March 24, 2006, 08:50:59 PM »

je suis revenu en debian stable pensant que ça marcherait mieux, vu que les paquets étaient unstable.
Ca a marché pendant 20 mins jusqu'à ce que je reboote l'ordi(kernel 2.6.13.4=>2.6.16) et là idem.
Impossible aussi de compiler wxgtk, on me demande à nouveau de compiler gtk+2.

A croire que les utilisateurs de debian sont maudits.
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
Re: problème de lancement
« Reply #14 on: March 24, 2006, 09:01:38 PM »

Je pense que c'est suffisant d'installer libgtk2.0-dev au lieu de compiler tout le gtk+
Aprés il est censé marcher...
Logged
Pages: [1] 2