aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Under OpenBSD - coming back !!  (Read 3927 times)

fa²

  • Guest
Under OpenBSD - coming back !!
« on: February 28, 2004, 01:49:33 PM »

Hi all :)

I've some little problems...

The first seems to be the same as here ( http://www.amule.org/amule/thread.php?threadid=1199&sid=&threadview=0&hilight=&hilightuser=0&page=1 ) : aMule crash sometimes without error messages (just trap, core dumped) and i've to remove all files from the incoming directory to fix the problem... when a download is ok- aMule crash, i must move the file and run it again :( (my incoming directory is /download ; temp directory is /download/temp)

Second : i've some error messages in msg-boxes, often "can't open file '/root/.aMule/logfile' (error 9 : bad file descriptor)". I've tryed to remove logfile and some other files but aMule don't like it :rolleyes:

Thanks in advance ;)
Logged

croaker

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: Under OpenBSD - coming back !!
« Reply #1 on: March 07, 2004, 04:13:08 AM »

Regarding your second question, try ulimit -n 1024
Read the ulimit man page; OpenBSD has excellent man pages! :)
(or should it be person pages in this time of politcal correctness? :)

Why are you running amule as root?

Hope this helps.

Croaker
Logged

fa²

  • Guest
Re: Under OpenBSD - coming back !!
« Reply #2 on: March 07, 2004, 11:20:47 PM »

Quote
Originally posted by croaker
Regarding your second question, try ulimit -n 1024
Read the ulimit man page; OpenBSD has excellent man pages! :)
(or should it be person pages in this time of politcal correctness? :)

Why are you running amule as root?

Hope this helps.

Croaker

Hum... it seems to work.... i will post again later to confirm :P

I'm running aMule as root cause ... i'm lazy :rolleyes: i use this BSD-box only for firewalling & aMule... i've no critical-data so... nothing to loose ;)

Thanks :)
« Last Edit: March 07, 2004, 11:21:07 PM by fa² »
Logged

fa²

  • Guest
RE: Under OpenBSD - coming back !!
« Reply #3 on: March 11, 2004, 01:14:47 AM »

The second problem is solved with ulimit -n 2048
(rare error messages with 1024, but...)

What's up for the first one ? Some idea ?

Quote
Originally posted by fa²
I've some little problems...

The first seems to be the same as here ( http://www.amule.org/amule/thread.php?threadid=1199&sid=&threadview=0&hilight=&hilightuser=0&page=1 ) : aMule crash sometimes without error messages (just trap, core dumped) and i've to remove all files from the incoming directory to fix the problem... when a download is ok- aMule crash, i must move the file and run it again :( (my incoming directory is /download ; temp directory is /download/temp)

Thanks in advance ;)

I've the same crashes when aMule complete a file.... I must run 3/4 times aMule to have the file completed with success ;(
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5822
Re: Under OpenBSD - coming back !!
« Reply #4 on: March 11, 2004, 12:24:23 PM »

no idea on my side.
Logged

fa²

  • Guest
Re: Under OpenBSD - coming back !!
« Reply #5 on: March 15, 2004, 06:14:27 PM »

Hum... some news, hope it help...

I've put some old temp files from an old eMule install in the aMule temp dir... (*.part / *.part.met / *.part.met.bak). I've restarted aMule. aMule shown me these downloads, status Hashing, and after some seconds... crash... restarted, some seconds, crash... ect ... ect ...
After about 10 crash (grrrr) i've tried to unplug the network cable (internet via network) and restarted aMule. Surprise : aMule have completed the hash of all the new files !! I've pluged the network cable, pressed Connect, and it's now downloading...

aMule crash only when it done long operations on disk (completing, hashing, ect...)

I don't know how to do...
I've an core dump file if you want...
« Last Edit: March 15, 2004, 06:16:30 PM by fa² »
Logged

fa²

  • Guest
Re: Under OpenBSD - coming back !!
« Reply #6 on: March 16, 2004, 01:48:39 PM »

Hum... some news again...

aMule seems work perfectly without crash if i stay on the server page...

Disconnect the network cable is like to force aMule to display nothing (no changes to display).

Keep in mind i've a slow machine (PII300 - 128Mo)...

Crashes can come from display problems when disk or cpu are busy ??
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5822
Re: Under OpenBSD - coming back !!
« Reply #7 on: March 16, 2004, 02:02:19 PM »

can. strange.

/me thinking
Logged

fa²

  • Guest
Re: Under OpenBSD - coming back !!
« Reply #8 on: March 19, 2004, 07:50:25 PM »

no more crash since i don't ask aMule to display transfert status...
4 days and some files downloded since :)
Logged