aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2 3 ... 10

Author Topic: aMule 2.2.x and SVN (with amuled e amulegui) Tiger/Leopard Universal Binary  (Read 177072 times)

gtoso

  • Official MacOSX Packager
  • Full Member
  • ***
  • Karma: 24
  • Offline Offline
  • Posts: 208

Hi,
I compiled recent versions of aMule for Tiger/Leopard Universal Binary
(Daemon, Remote GUI and Buildscripts Included).

aMule and aMuleGUI (Buildscripts Included):

Stable versions

2.2.5:

> 2.2.5 Tiger/Leopard   aMule project official mirror at SourceForge
 MD5 Sum: 9b68c2d02b43b116d5b83aa50442f9ae
> 2.2.5 Tiger/Leopard aDEBUG Build 2
 MD5 Sum: 5fbbae42f0c9866a39a23c209e422c1b
> 2.2.5 Leopard
 MD5 Sum: 4fbbc1c20297d9a2ecef942948e31022

> Experimental 2.2.5 Leopard with some insanely optimizations: maybe fast, maybe slow, maybe instable
 MD5 Sum: cfdcf856c898ba15445f2e7794e29788

Notes:
Tested on Leopard/Intel and when possible on Tiger/PPC.

Build changes:
Applied to wxMac 2.8.10 this patch.
Upgraded crypto++ from 5.5.2 to 5.6.0.
10.4 SDK for Tiger/Leopard builds
10.5 SDK and gcc 4.2.1 for Leopard builds
aDEBUG: only aMule with DEBUG and NO optimizations (exept SVN builds)
I removed GeoIP from file names: all my recently builds have GeoIP enabled, unless you see NOGeoIP.

> 2.2.4
New build: first one was broken.
DON'T USE 2.2.4: it has some serious bugs, see here.

Notes:
While under Tiger/PPC amuleweb works fine, under Leopard/Intel it has problems (same problem in 2.2.3).
Tested on Tiger/PPC and Leopard/Intel, please let me know how work.

Build changes:
First version compiled on Leopard/Intel: 10.5 SDK with MACOSX_DEPLOYMENT_TARGET=10.4.
aDEBUG = aMule only DEBUG:
wxMac compiled with optimizations and no debug, but aMule compiled with debug and optimizations.
Disabled wxWidgets 2.6 compatibility in wxMac 2.8.10.
No more stripped binaries.
Added WxCas and aLinkCreator applications.
More Mac friendly DMG  :P

SVN (Development version)

> Revision 9655 07 Jun 2009
 MD5 Sum: 14a8ecd551e69570472e64d0dd43aa17

> Revision 9642 Build 2 31 May 2009
 MD5 Sum: bbaec4dca1b7dc5c798fa1157072013c

Notes:
Visualization defect fixed disabling timer logic as suggested by Stu Redman.
It should be fixed in 9645, disabling timer logic for Mac  :(

> Revision 9642 31 May 2009
 MD5 Sum: baf648e78825672b4f5f4e5b58ac58b6

Notes:
Visualization defect only partially fixed.

Build changes:
Fixed version number in Application bundles.

> Revision 9623 25 May 2009
 MD5 Sum: b29ab1c3b6203f2db5f0f8600aaacd8a

Notes:
I encountered some "graphics" problems, I don't think that it's a compilation problem,
asap I'm going to rebuild (in the same way) the r9602 (that works fine) and the latest revision.
Then, in the event, I'll post the problem details.
Updates:
r9602, compiled in the same way of r9623, works fine, so it's a bug introduced between these 2 revisions.
The same in r9641. I posted details here.

Build changes: (see 2.2.5)
Patched muuli_wdr.cpp to make source compatible to wx 2.8 without 2.6 backward compatibility.

> Revision 9602 11 May 2009
 MD5 Sum: ee8a26708c28fc548c0d3b7787be7215

Build changes from 2.2.4:
Applied to wxMac 2.8.10 this patch.
ReEnabled wxWidgets 2.6 compatibility in wxMac 2.8.10, see here.

Here you can find my old dev packages.

Notes on file names:

DEBUG: both wxMac and aMule with DEBUG enabled and without any optimizations
aDEBUG: only aMule with DEBUG enabled (SVN builds with optimizations)

OSX10.4+: Universal Binary for Tiger and above (wxMac/aMule/dependences compiled with 10.4 SDK and Apple gcc 4.0.1)
OSX10.5: Universal Binary for Leopard (wxMac/aMule/dependences compiled with 10.5 SDK and Apple gcc 4.2.1)

FastG4+: Experimental! wxMac/aMule insanely optimized (G4-G5/Intel)
FastG5+: Experimental! wxMac/aMule insanely optimized (G5/Intel)

..._N.dmg: Build number N.

.dmg: Apple disk image (what you want)
.md5/.asc: checksum/signature, if you don't understand, ignore it.

Compiled on OSX 10.5.7 Intel, XCode 3.1.2, MacPorts.
In OSXBuild directory you can find the options that I used to configure wxMac and aMule, the modified mac_packager script and the patches used.

Compared to the usual aMule.app I included some things:
cas, alcc, mulefileview and amuled in MacOS,
man and skins in SharedSupport.

I also included GeoIP/IP2country:
it shows the users and servers country with nice flags.
GeoLite Country database included in Application bundles.

I included too:
aMuleGUI.app: Remote GUI
aLinkCreator.app: Tool for computing ed2k link from a file
WxCas.app: GUI aMule statistics

ATTENTION!
if you want that amuled start amuleweb, put its path in the PATH environment variable, at example:

Code: [Select]
PATH="/Applications/aMule-SVN/aMule.app/Contents/MacOS:$PATH" amuled -f
I suggest to add to .profile something as it:

Code: [Select]
export PATH=/Applications/aMule-SVN/aMule.app/Contents/MacOS:$PATH
so you can simply invoke amulecmd, amuled, ed2k, ...
and in Tiger the relative man pages (man amuled).
In Leopard the AUTOPATH doesn't work, so for man pages use the MANPATH variable:

Code: [Select]
export MANPATH=/Applications/aMule-SVN/aMule.app/Contents/man:$MANPATH
« Last Edit: January 03, 2011, 10:11:53 PM by mirko.g »
Logged

iprecious

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: aMule CVS compiled (with amuled e amulegui) Universal Binary Tiger
« Reply #1 on: December 07, 2007, 07:11:36 PM »

Hey Toso,

thank's a lot for the packages. I tried tocompile it myself, butr some weirdish mistak cropped up, when i tried to install wxMac.

Could you gibe me one hint how to bring the daemon to work?

I'm not that skilled with the terminal up to know.


Regards

joh
Logged

Bandeira

  • Jr. Member
  • **
  • Karma: 2
  • Offline Offline
  • Posts: 97
Re: aMule CVS compiled (with amuled e amulegui) Universal Binary Tiger
« Reply #2 on: March 21, 2008, 04:08:50 AM »

Please, update aMule CVS  binary.
Logged

gtoso

  • Official MacOSX Packager
  • Full Member
  • ***
  • Karma: 24
  • Offline Offline
  • Posts: 208
Re: aMule CVS compiled (with amuled e amulegui) Universal Binary Tiger
« Reply #3 on: April 12, 2008, 05:14:57 PM »

Please, update aMule CVS  binary.

I tried but I need help:

Now amule needs cryptopp,
all my attempts to compile cryptopp 5.5.2 universal binary failed :-(
Help me, please.

If I remember correctly I modified GNUmakefile line 1 so:
CXXFLAGS += -DNDEBUG -g -O2
and I tried:
CXXFLAGS="-isysroot /Developer/SDKs/MacOSX10.4u.sdk -arch i386 -arch ppc" make
but compile failed at integer.cpp
For more detail I have to retry to compile it.

So I compiled cryptopp native for PPC and obviously amule failed to compile universal...
But amule fails even to compile for PPC, at some point it try to compile universal !?!
I recompile wxMac for PPC, but it isn't the problem...

The problem seems GDLIB_LDFLAGS in the amule Makefiles...
I'll try to recompile gd not universal...

Logged

gtoso

  • Official MacOSX Packager
  • Full Member
  • ***
  • Karma: 24
  • Offline Offline
  • Posts: 208
Re: aMule CVS compiled (with amuled e amulegui) Universal Binary Tiger
« Reply #4 on: April 12, 2008, 08:34:22 PM »

Now amule needs cryptopp,
all my attempts to compile cryptopp 5.5.2 universal binary failed :-(
Help me, please.

If I remember correctly I modified GNUmakefile line 1 so:
CXXFLAGS += -DNDEBUG -g -O2
and I tried:
CXXFLAGS="-isysroot /Developer/SDKs/MacOSX10.4u.sdk -arch i386 -arch ppc" make
but compile failed at integer.cpp
For more detail I have to retry to compile it.

I found this,
I have successfully compiled cryptopp as universal binary so:
CXXFLAGS="-isysroot /Developer/SDKs/MacOSX10.4u.sdk -arch i386 -arch ppc -DCRYPTOPP_DISABLE_ASM" make

Now I'm patching MacPorts libcryptopp Portfile to install it by ports,
ASAP I'll compile amule.

Logged

gtoso

  • Official MacOSX Packager
  • Full Member
  • ***
  • Karma: 24
  • Offline Offline
  • Posts: 208
Re: aMule CVS compiled (with amuled e amulegui) Universal Binary Tiger
« Reply #5 on: April 18, 2008, 10:20:37 PM »

I compiled 20080414 snapshot,
it should also run on Leopard  ;D :
I tested my 20071209 build on 10.5.1 and it works fine.

I compiled 20080416 with geoip and I'm testing it.

Logged

hardtraks

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13

Works on Tiger PPC  ;D
Thank you very much gtoso
Logged

eisa01

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 101

Tested on Leopard 10.5.2 PPC.

Thanks!
Logged

Crawler

  • Guest

I get a lot of those on Leopard 10.5.2 - didn't get them with the last build I used (02/2008):

Logger.cpp(269): Fehler: failed to flush the file '/Volumes/HHD/aMule/ed_temp/001.part.met.bak' (error 9: Bad file descriptor)
Logger.cpp(269): Fehler: failed to flush the file '/Volumes/HHD/aMule/ed_temp/001.part.met.backup' (error 9: Bad file descriptor)
Logged

xplode_me

  • Newbie
  • *
  • Karma: 1
  • Offline Offline
  • Posts: 18
    • http://linuxpt.dyndns.org

Crawler do you have that same problem with the latest cvs tarball?
Logged
xplode_me

gtoso

  • Official MacOSX Packager
  • Full Member
  • ***
  • Karma: 24
  • Offline Offline
  • Posts: 208

I get a lot of those on Leopard 10.5.2 - didn't get them with the last build I used (02/2008):

Logger.cpp(269): Fehler: failed to flush the file '/Volumes/HHD/aMule/ed_temp/001.part.met.bak' (error 9: Bad file descriptor)
Logger.cpp(269): Fehler: failed to flush the file '/Volumes/HHD/aMule/ed_temp/001.part.met.backup' (error 9: Bad file descriptor)

I get the same errors with my 20080416 and this too:
2008-04-21 22:17:01: Logger.cpp(269): Error: failed to flush the file '/Users/gtoso/Library/Application Support/aMule/logfile.bak' (error 9: Bad file descriptor)

But logs and downloads seem work fine.
I don't remember if it happended with 20080414.
I'll try to look in this forum and I'm going to compile a new amule snapshot.
Logged

gtoso

  • Official MacOSX Packager
  • Full Member
  • ***
  • Karma: 24
  • Offline Offline
  • Posts: 208
Re: aMule CVS compiled (with amuled e amulegui) Universal Binary Tiger
« Reply #11 on: April 22, 2008, 12:30:12 AM »

I compiled 20080416 with geoip and I'm testing it.

It works, but I noticed some strange things:
1) Some errors (about logfile.bak and *.part.met.bak/backup) that do not seem to affect the operation: "error 9: Bad file descriptor"
2) After some tests (amule; amuled, amulecmd, amulegui and web access, change preferences by amule and by amulegui), amule didn't open anymore by icon or open command, but it opened launching directly amule  ???
I copied aMule.app and the copy opened correctly,
I replaced aMule.app and it worked.

I don't think these problems are related to geoip.

You need GeoIP.dat in /opt/local/share/GeoIP/
Try:
Code: [Select]
sudo mkdir -p /opt/local/share/GeoIP
cd /opt/local/share/GeoIP
#sudo chgrp admin .
sudo chmod g+w .
wget http://www.maxmind.com/download/geoip/database/GeoIP.dat.gz
gzip -d GeoIP.dat.gz
Logged

gtoso

  • Official MacOSX Packager
  • Full Member
  • ***
  • Karma: 24
  • Offline Offline
  • Posts: 208

I get a lot of those on Leopard 10.5.2 - didn't get them with the last build I used (02/2008):

Logger.cpp(269): Fehler: failed to flush the file '/Volumes/HHD/aMule/ed_temp/001.part.met.bak' (error 9: Bad file descriptor)
Logger.cpp(269): Fehler: failed to flush the file '/Volumes/HHD/aMule/ed_temp/001.part.met.backup' (error 9: Bad file descriptor)

The problem seems resolved, see here.

xplode_me I see you are able to compile amule snapshots quickly,
can you make your builds publicly available?

At the moment I'm compiling on a G3 400 ...
« Last Edit: April 22, 2008, 07:55:49 AM by gtoso »
Logged

Crawler

  • Guest

Additionaly to the above mentioned errors I get very high cpu-loads with 04/14/2008. I have about 15 files in my download-list, 2 of them are active (waiting/downloading) the others are paused. I didn't have that high cpu-loads with the last build from february.
Logged

GodzFire

  • Newbie
  • *
  • Karma: -4
  • Offline Offline
  • Posts: 29

Sadly, every aMule build that I've tried or has been posted has failed. The same thing happens each time, I double click the icon to open it, it shows up in the Dock as if it's opening, and then just goes away.

Unfortunately, I'm stuck with the "most recent" one that works which, for me, is the CVS from Tues, Oct 2nd, 2007 :-

EDIT: Using Mac Pro, OSX 10.4.11 by the way
Logged
Pages: [1] 2 3 ... 10