aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: aMule SVN 01.23.2008 crash  (Read 7300 times)

Brezhonneg

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 23
aMule SVN 01.23.2008 crash
« on: February 29, 2008, 10:11:04 AM »

It does crash every now and then. Installed from the db found on this forum on a Kubuntu 64bit system. I was not in front of the computer when this happened...

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN using wxGTK2 v2.8.4 (Snapshot: Wed Jan 23 07:01:57 CET 2008)
Running on: Linux 2.6.22-14-generic x86_64

[2] std::basic_string<char, std::char_traits<char>, std::allocator<char> >::~basic_string() in amule [0x454e0f]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x2ae3b435864c]
[4] ?? in /lib/libpthread.so.0 [0x2ae3b2e03100]
[5] wxMenuItemList::~wxMenuItemList() in amule [0x682442]
[6] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x61b2f5]
[7] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x61b751]
[8] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x61bc26]
[9] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x2ae3b435466f]
[10] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0x2ae3b435480f]
[11] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x2ae3b4354959]
[12] wxTimerBase::Notify() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ae3b3cdbd76]
[13] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0x2ae3b3bd2a14]
[14] ?? in /usr/lib/libglib-2.0.so.0 [0x2ae3b680d70b]
[15] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0x2ae3b680cfd3]
[16] ?? in /usr/lib/libglib-2.0.so.0 [0x2ae3b68102dd]
[17] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x2ae3b68105ea]
[18] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x2ae3b6e0c883]
[19] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ae3b3bca50d]
[20] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ae3b3c5bc8b]
[21] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x2ae3b42f380c]
[22] std::ostream::operator<<(bool) in amule [0x612ce6]
[23] __libc_start_main in /lib/libc.so.6[0x2ae3b4f99b44]
[24] wxAppBase::MainLoop() in amule[0x44f1a9]


--------------------------------------------------------------------------------
Abandon (core dumped)
Logged

Brezhonneg

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 23
Re: aMule SVN 01.23.2008 crash
« Reply #1 on: February 29, 2008, 10:13:48 AM »

Wahoo... I restarted and got a crash again in the time it took for me to post the previous report. Must be the same but heck, here it is:

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN using wxGTK2 v2.8.4 (Snapshot: Wed Jan 23 07:01:57 CET 2008)
Running on: Linux 2.6.22-14-generic x86_64

[2] std::basic_string<char, std::char_traits<char>, std::allocator<char> >::~basic_string() in amule [0x454e0f]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x2b787536164c]
[4] ?? in /lib/libpthread.so.0 [0x2b7873e0c100]
[5] wxMenuItemList::~wxMenuItemList() in amule [0x682442]
[6] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x61b2f5]
[7] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x61b751]
[8] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x61bc26]
[9] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x2b787535d66f]
[10] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0x2b787535d80f]
[11] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x2b787535d959]
[12] wxTimerBase::Notify() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2b7874ce4d76]
[13] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0x2b7874bdba14]
[14] ?? in /usr/lib/libglib-2.0.so.0 [0x2b787781670b]
[15] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0x2b7877815fd3]
[16] ?? in /usr/lib/libglib-2.0.so.0 [0x2b78778192dd]
[17] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x2b78778195ea]
[18] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x2b7877e15883]
[19] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2b7874bd350d]
[20] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2b7874c64c8b]
[21] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x2b78752fc80c]
[22] std::ostream::operator<<(bool) in amule [0x612ce6]
[23] __libc_start_main in /lib/libc.so.6[0x2b7875fa2b44]
[24] wxAppBase::MainLoop() in amule[0x44f1a9]


--------------------------------------------------------------------------------
Abandon (core dumped)


It usually takes a lot longer between two crashes.
Logged

Brezhonneg

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 23
Re: aMule SVN 01.23.2008 crash
« Reply #2 on: February 29, 2008, 10:21:05 AM »

I checked my dmesg, and here is what I found:

UDP: bad checksum. From xxx.xxx.xxx.xxx:xxxxx to yyy.yyy.yyy.yyy:yyyyy ulen 44

I removed the IPs. The second one was my local IP (local network).
 I don't know the timing for sure, so this may or may not be related with the crashes...

EDIT: Note that I only got one message like this, while I got two crashes... If this error message has to be related with any of the two crashes, it must be with the first one because the timing does not match the second one.
« Last Edit: February 29, 2008, 10:22:43 AM by Brezhonneg »
Logged

Brezhonneg

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 23
Re: aMule SVN 01.23.2008 crash
« Reply #3 on: March 01, 2008, 03:04:40 AM »

I have been getting very frequent crashes always with the same trace since yesterday. What seems to have triggered this string was the addition of two popular files (with many many sources) in my download list, while I only had like a dozen of less popular files (10-20 sources top) before. I stopped one of the two popular files, I will see if that decreases the crash occurence at least. aMule is virtually unusable with that many crashes.

As far as the UPD checkum thingy in the kernel log goes, there is definitely no clear realtion with the crash, or at least it is not direct.
Logged

Brezhonneg

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 23
Re: aMule SVN 01.23.2008 crash
« Reply #4 on: March 03, 2008, 05:02:08 AM »

Sadely, my test with stopping one of the two popular files was not very conclusive. Crashes kept happening seemingly randomly, then stopped. Since then, the first popular file download was completed, I removed it from the list and resumed the second file, still no crash in 48h. So, I am thinking that this crash is triggered by some random event, which occurence is more frequent when you connect to more sources. Perhaps one of those stupid automatic spam messages we receive from time to time from some sources? Well, it could be anything I guess, I am sorry this report is not very helpful. Let me know if you can think of any more info/test I could provide/carry out.

Cheers
Logged

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: aMule SVN 01.23.2008 crash
« Reply #5 on: March 04, 2008, 03:14:16 AM »

Hi Brezhonneg,

You could try to compile aMule with debug information so that you are able to provide a more accurate backtrace. See this link for clues:
http://www.amule.org/wiki/index.php/Backtraces

Cheers!
Logged

emisca

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: aMule SVN 01.23.2008 crash
« Reply #6 on: March 14, 2008, 07:40:14 PM »

I have very similar crashes, while amule is only uploading. This occurs with the amule cvs snapshots of the last 2-3 weeks. That's bad....
I'll follow the guidelines to produce more useful stack traces. For now I have this. I'm on amd64 architecture, but I can reproduce sistematically the crash also on a 32 bit chroot.

The distribution used is debian Etch with vollkstener packages compiled with pbuilder for amd64. I've also backported the 20080309 snapshot from debian experimental, but no difference.

I have also the core file, where I can send it?

I noticed that amule process size grows with the time (as usually  :o).

amuled with the same configuration doesn't crashes, but starts to use the 100% of the cpu, and that's is even worse.


----------------------------------------------------------------------------------------------------

Initialising aMule
Checking if there is an instance already running...
No other instances are running.
ListenSocket: Ok.
Loading temp files from /home/emi/.aMule/Temp.
HTTP download thread started

All PartFiles Loaded.
Host: peerates.net:80
URL: http://peerates.net/servers.php
Response: 200 (Error: 0)
Download size: 1525
HTTP download thread ended
HTTP download thread started
Host: www.gruk.org:80
URL: http://www.gruk.org/server.met
Response: 200 (Error: 0)
Download size: 3521
HTTP download thread ended

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://www.amule.org/wiki/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN using wxGTK2 v2.8.7 (Snapshot: Sun Mar  9 07:01:55 CET 2008)
Running on: Linux 2.6.18.8-xen x86_64

[2] wxThreadHelperThread::~wxThreadHelperThread() in amule [0x444145]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x3598afa97c]
[4] ?? in /lib/libpthread.so.0 [0x359400c410]
[5] wxMenuItemList::~wxMenuItemList() in amule [0x570a38]
[6] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x515386]
[7] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x515ad2]
[8] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x3598af67df]
[9] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0x3598af697e]
[10] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x3598af6ac9]
[11] wxTimerBase::Notify() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x36094f27a6]
[12] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0x36093e96b4]
[13] ?? in /usr/lib/libglib-2.0.so.0 [0x360782ce1b]
[14] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0x360782c913]
[15] ?? in /usr/lib/libglib-2.0.so.0 [0x360782f75d]
[16] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x360782fa46]
[17] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x3608b2b6b2]
[18] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x36093e0e6d]
[19] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x36094733bb]
[20] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x3598a95cbc]
[21] std::basic_string<char, std::char_traits<char>, std::allocator<char> > std::operator+<char, std::char_traits<char>, std::allocator<char> >(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) in amule [0x510882]
[22] __libc_start_main in /lib/libc.so.6[0x3593a1c4ca]
[23] __gxx_personality_v0 in amule[0x44339a]
Logged

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 940
  • Offline -> Studying...
Re: aMule SVN 01.23.2008 crash
« Reply #7 on: March 14, 2008, 08:46:29 PM »

Please use a more recent versi├│n (lastest 2008-03-03):

http://forum.amule.org/index.php?topic=13700.0

emisca

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: aMule SVN 01.23.2008 crash
« Reply #8 on: March 16, 2008, 03:41:19 PM »

Hey, I was using:
Current version is: aMule SVN using wxGTK2 v2.8.7 (Snapshot: Sun Mar  9 07:01:55 CET 2008)
that is newer than 2008-03-03...
anyway. I compiled it with debug informations, installed all debug symbols for wx and glib, and ran amule from gdb. I crashed after one day, under the same circumstances (only uploading, no downloads...).

Attached there are the backtraces. I have also the core dump, but it's big so tell me where I can upload it, if you need it.

Feel free to move this thread on the backtraces section of the forum....

Thanks

Logged

emisca

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: aMule SVN 01.23.2008 crash
« Reply #9 on: March 16, 2008, 03:44:57 PM »

I forgot, as it seems to be a problem related to the tray icon, as the full backtrace says..... I've started amule under gdb and disabled the tray icon.
Let's wait until it crashes or perhaps let's see what happens.
Logged

kuanto

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 29
Re: aMule SVN 01.23.2008 crash
« Reply #10 on: March 16, 2008, 04:48:17 PM »

Aren't the first backtrace and the last one differents? I mean, the first one says nothing about MuleTrayIcon, but the last one does.

Anyway, the MuleTrayIcon crash was previously reported here:

http://forum.amule.org/index.php?topic=13914.0
http://forum.amule.org/index.php?topic=14141.0

AFAIK, this crash is triggered when you get a message with geo-ip enabled (ie. having compiled with --enable-geoip). This is probably your random crash which is more likely to happen when you connect to more sources. The way to avoid the crash is just filtering all messages (or compiling without geo-ip).

In the other hand: it's a crash very easy to reproduce with two instances of aMule, could anyone confirm my theory??

Hope it helps!! ;)
Logged

emisca

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: aMule SVN 01.23.2008 crash
« Reply #11 on: March 16, 2008, 05:34:42 PM »

so let's wait if the next crash will be of the first type or the second....  :o
Logged

kuanto

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 29
Re: aMule SVN 01.23.2008 crash
« Reply #12 on: March 16, 2008, 06:14:42 PM »

so let's wait if the next crash will be of the first type or the second....  :o

Oops, I forgot to say that disabling TrayIcon had no effect: aMule keeps crashing on arrival of a message.



I can't imagine how these 3 things are related: a crash on a message arrival, in a function to display TrayIcon, but happening only when compiled with geo-ip enabled???  ???
Logged

emisca

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: aMule SVN 01.23.2008 crash
« Reply #13 on: March 16, 2008, 06:50:11 PM »

So my test is useless.. I'll try to disable geo-ip completely (as it is also useless for my usage) and I'll wait if the other kind of crash will appear or not.
Logged

Brezhonneg

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 23
Re: aMule SVN 01.23.2008 crash
« Reply #14 on: March 23, 2008, 05:55:12 AM »

By the way, just so you know, I did not abandon this topic. I stopped posting because I do not have much to say. I downloaded SVN the 5th of March, compiled with debugging (and geo-ip), and I'm running it inside gdb. No crash has occured since then, even though I reproduced the same situation a couple of times (popular files with many sources). I like the messaging theory though I do not have any facts to back it up.
Logged
Pages: [1] 2