aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 ... 4 5 [6]

Author Topic: *REQ* New Universal/Intel Compile  (Read 36625 times)

isulzer

  • Jr. Member
  • **
  • Karma: 2
  • Offline Offline
  • Posts: 62
Re: *REQ* New Universal/Intel Compile
« Reply #75 on: April 01, 2008, 10:13:36 PM »

k so. a manual compile/install of libiconv as static only then specified the directory with --with-libiconv-prefix= worked... least it SAYS it linked with the libiconv.a library.
Logged

blackfede

  • Jr. Member
  • **
  • Karma: 3
  • Offline Offline
  • Posts: 70
Re: *REQ* New Universal/Intel Compile
« Reply #76 on: April 01, 2008, 10:49:36 PM »

Sorry, probably i miss the point, but why are you tring to do static link? To redistribute the aMule.app without the problem of  libs dependencies? So, if this is the point, why don't use the MacOs standard way? Copy all the libs in the Framework dir in the .app bundle, then use otool to change the reference. Here i've explaindex how to do.
« Last Edit: April 02, 2008, 03:06:48 PM by blackfede »
Logged
All troll are idiots and will go in /dev/null

isulzer

  • Jr. Member
  • **
  • Karma: 2
  • Offline Offline
  • Posts: 62
Re: *REQ* New Universal/Intel Compile
« Reply #77 on: April 01, 2008, 11:09:23 PM »

because im trying to get amule to work on both tiger and leopard. Amule seems to require a later version of libiconv thats not available on the 10.4.11 system. I coupd be wrong here as i dont have tiger anymore. but a compile that works on both has to take this into account.The static compile adds very little to the binary(something like 50,000 bytes) and it fixes the cross compatibility.
Logged

harlock59

  • Jr. Member
  • **
  • Karma: -1
  • Offline Offline
  • Posts: 50
    • Youmé-TECH - PC Mac Linux Troubleshootings & Website / Software Developper
Re: *REQ* New Universal/Intel Compile
« Reply #78 on: October 22, 2008, 11:46:03 PM »

I know that i'm a bit presompteous asking for that, but wouldn't it be possible to make a shell script that would automate all of the downloads and compile phases, and you would only have to execute it to make the whole compilation having only the Mac OS X dev tools already on the Mac...

i know it's possible, but of course, no one would do it (maybe me ?)

and i don't know if it's possible to make another shell script that would update the already compiled aMule CVS to the latest version of the common aMule CVS...

bye bye guys...
Logged
iMac g4 leopard powerpc
www.youmetech.fr

kreegee

  • Full Member
  • ***
  • Karma: 2
  • Offline Offline
  • Posts: 161
    • http://kreegee.cycovery.com
Re: *REQ* New Universal/Intel Compile
« Reply #79 on: October 23, 2008, 04:41:13 AM »

harlock59: check out my Xcode project for aMule. it's actually most of what you want (once its finished)

http://forum.amule.org/index.php?topic=15826.0
Pages: 1 ... 4 5 [6]