aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Umlaute werden nicht gezeigt  (Read 6784 times)

karsten_HG

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Umlaute werden nicht gezeigt
« on: August 14, 2005, 09:36:59 AM »

aMule 2.0.3-1 installiert und läuft, jedoch zeigt er die Umlaute nicht an, das ist zwar kosmetisch, aber irgendwie stört das.
wer weis rat? hat das irgendwie mit wxGtk zu tun?

Gruß
Karsten
Logged
Wer Rechtschreibfehler findet darf sie behalten!

matti

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
RE: Umlaute werden nicht gezeigt
« Reply #1 on: October 29, 2005, 09:57:38 AM »

Quote
Originally posted by karsten_HG
aMule 2.0.3-1 installiert und läuft, jedoch zeigt er die Umlaute nicht an, das ist zwar kosmetisch, aber irgendwie stört das.
wer weis rat? hat das irgendwie mit wxGtk zu tun?

Gruß
Karsten

Habe mit Suse 9.3 das gleiche Problem, gibt es schon eine Lösung?
Gruß Matti
Logged

matti

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
Re: Umlaute werden nicht gezeigt
« Reply #2 on: October 29, 2005, 10:11:11 AM »

noch als Nachtrag, installiert sind filgende Pakete
amule 2.03 using wxGTK1 v2.6.0 (OS:Linux)

Gruß Matti
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4249
Re: Umlaute werden nicht gezeigt
« Reply #3 on: October 29, 2005, 11:43:21 AM »

ok hier die antwort:

wxGTK1--also mti gtk1.2 kann kein utf8...

der po string ist aber ein utf-8 string....das heist er wrid deshalb nicht richtig dargestellt, weil gtk1.2 das nicht unterstützt....

ein lsg wäre es --> wxGTK mit gtk2 support zu bauen, heir würde alles funktionieren....

doch wxGTK mit gtk2 hat bis zur version 2.6.1 ein mem-leak problem, ab wxGTK-2.6.2 funktioneirt dies wunderbar, doch haben die jungs von wxWidgets einen bug eingebaut, welcher die meisten localen(sprachen) ausser eng, abstürzen lässt...

wenn du also aMule mit umlauten und wxGTK- gtk2 willst, musst du im moment auf wx-cvs zurückgreifen....

tata
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

thedude0001

  • evil bugfinder ;)
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 830
Re: Umlaute werden nicht gezeigt
« Reply #4 on: October 29, 2005, 02:39:54 PM »

/me wird mal wieder daran erinnert warum er wx so mag...
Logged
Das Schlimme auf dieser Welt ist
daß die Dummen so selbstsicher sind
und die Gescheiten so voller Zweifel.

matti

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
Re: Umlaute werden nicht gezeigt
« Reply #5 on: October 30, 2005, 10:51:35 AM »

na das ist doch mal eine flotte Antwort. Danke! Dann werd ich damit leben bis das Bug behoben ist.

viele Grüße
Matti
Logged