aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule 2.2.2-1 su Ubuntu 8.04  (Read 4554 times)

macman

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
aMule 2.2.2-1 su Ubuntu 8.04
« on: August 12, 2008, 01:32:10 PM »

Salve.

Ho appena installato aMule 2.2.2-1 secondo http://forum.amule.org/index.php?topic=15585.0
ma aMule non si esegue più. Con la versione precedente tratta dai repository di default di Ubuntu 8.04 funzionava tutto a meraviglia.

Se ora eseguo amule da terminale ottengo
manolo@manolo-laptop:~$ amule
amule: error while loading shared libraries: libbfd-2.17.so: cannot open shared object file: No such file or directory

Ho provato come descritto qui, ma ottengo

ln: accessing `/usr/lib/libbfd-2.17.50.0.17.so': No such file or directory

Inoltre
manolo@manolo-laptop:~$ sudo find / -iname libbfd*
/usr/lib/libbfd-2.18.0.20080103.so
find: /home/manolo/.gvfs: Permission denied

Suggerimenti? Grazie.
Saluto.
Logged

macman

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: aMule 2.2.2-1 su Ubuntu 8.04
« Reply #1 on: August 12, 2008, 01:45:36 PM »

Ho "risolto" nella seguente maniera, modificando leggermente i parametri quel comando 'ln' di cui sopra basandomi sul risultato della ricerca tramite 'find' di cui sopra:

sudo ln /usr/lib/libbfd-2.18.0.20080103.so /usr/lib/libbfd-2.17.so

Avevo provato anche con
sudo ln /usr/lib/libbfd-2.18.0.20080103.so /usr/lib/libbfd-2.18.so

ma ottenevo sempre lo stesso errore.
Logged

macman

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: aMule 2.2.2-1 su Ubuntu 8.04
« Reply #2 on: August 16, 2008, 12:48:36 PM »

Purtroppo la soluzione trovata non è delle migliori. Nonostante in
aMule -> Preferenze -> Generale
abbia attivato l'opzione, non mi funziona il minimizzare in "tray icon" (con la versione scaricata da Synaptic mi funzionava alla grande).

Sto pensando di ritornare alla vecchia versione da Synaptic:
- come disinstallare la versione installata da sorgenti?
- come rimuovere tutte le dipendenze della versione installata da sorgenti?
- ulteriori suggerimenti/considerazioni?

Grazie per l'attenzione.
Logged