aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: Me desaparece el contenido de la ventana.  (Read 6601 times)

SAC82

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Me desaparece el contenido de la ventana.
« on: June 10, 2004, 07:43:08 PM »

Hola,
Soy relativamente nuevo con el uso de amule. Anteriormente lo usaba en Suse (iba bien) pero ahora uso Knopixx y la versión de aMule 2.0.0rc3. Tengo configurado amule corectamente y me funciona bien. Lamentablemte cuando pasa un tiempo pequeño (un cuarto de hora por ejemplo). y minimizo y vuelvo a maximizar la ventana de amule o tengo amule en el System Tray y lo maximizo nuevamente resulta que la ventana de amule deja de mostrar los iconos, tablas en fin todo. Veo la ventana practicamente en blanco y obviamente es un serio problema ya que no se si esta funcionando, si baja o como van mis archivos. No se si esto os habra pasado a alguno de vosotros e intentado echar un vistazo a los threads anteriores para no escribir un hilo reduntante pero no he visto nada. Espero que me podais echar una mano.
Logged

SebaX

  • Forum/eMail Support Helper
  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 193
  • Las respuestas via e-Mail serán respondidas a la brevedad posible, tengan consideración que uno tambien tiene cosas que hacer, pero se hace lo posible por responder lo antes posible :D
    • http://www.sbmsbm.tk
Re: Me desaparece el contenido de la ventana.
« Reply #1 on: June 10, 2004, 08:13:10 PM »

Hola, qué tal?...
Lo que comentas se puede deber a diversos casos.
1.- Puede que JUSTO cuando hiciste eso terminó de bajar un archivo por lo tanto esta uniendo partes(en caso de que sea un archivo relativamente grande).
2.- Puede que estes bajando muuuuchos archivos, por ende, tiene que sacar sacar todos los datos gráficar la barra de progreso y ordenarlos, para poder mostrarlos por pantalla.
3.- Puede de que... (basandome en los 15min que decias), este haciendo hashing de los archivos si compartes muchos, o son muy grandes podría llegar a demorar muchísimo tiempo.
Los casos que te he comentado podría ser por que tienes muy poca RAM, o tu PC es muy lento :(... por que he tratado de  reproducir tu error y me funciona perfectamente. Si tengo algo de tiempo por que la U me tiene algo colapsado, instalaré knopixx a ver que onda ;), por que creo, que ademas debe estar pasando algo con la configuración de tu equipo.
Podrías tratar de dar más especificaciones del problema.

Chau, que estes bien :)... Cualquier duda solo hazla saber :D
« Last Edit: June 10, 2004, 08:13:49 PM by SebaX »
Logged
Student of Computer Science Engineering.
Linux Development, GNU/GPL Development.
User of Linux  :  Debian, Slackware 9.0-10.0, SuSE 8.0->9.1, Red Hat 6.0 ->Fedora 1
User of xBSD  :  FreeBSD 4.8->5.1.2 and OpenBSD 3.4
User of SunOS : Solaris 9->10

SAC82

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: Me desaparece el contenido de la ventana.
« Reply #2 on: June 10, 2004, 08:48:25 PM »

Hola,
Mi procesador es un AMD 1600 y tengo 512 de RAM. Supong que debería ser suficiente.
Sobre lo del numero y tamaño de archivos estoy bajando unos 20 archivos de 300 Mb. Aunque estoy practicamente seguro que cuando bajaba pocos tambien me pasaba.  Un vez que la pantalla se borra no se vuelve a poner bien. Espero haber aclarado un poco más el problema.
Gracias por vuestra rápida respuesta.
Sergio
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Me desaparece el contenido de la ventana.
« Reply #3 on: June 10, 2004, 10:52:48 PM »

Nah, es que se te ha colgado :-(
Puedes comprobarlo intentanto hacer una conexion con amuleCMD. Si falla (que es lo que pasará) es que se te ha colgado. Sino, pos posteo, porque algo raro pasa. Eso sí, no digas "falla" y tan feliz. Asegurate de que mientras funciona amuelCMD conecta y cuando sale eso en gris deja de coenctar.
Un saludo!
Logged

SAC82

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: Me desaparece el contenido de la ventana.
« Reply #4 on: June 11, 2004, 12:05:42 AM »

Quote
Originally posted by Jacobo221
es que se te ha colgado :-( Puedes comprobarlo intentanto hacer una conexion con amuleCMD. Eso sí, no digas "falla" y tan feliz.

Hola, He arrancado amule desde linea de comando (no lo habia hecho antes) y he visto el proceso que lleva (Loading, Sharing y hashing) de los archivos compartidos y aquellos que estan bajando. Me gustaria ver si se me cuelga  intentado hacer una conexion con amule CMD pero no se usar dicho comando. He mirado en la pagina man y tampoco me ha aclardo nada.

Supongo que llevaras razon y se colgara. Mi duda es como puedo evitar que se cuelgue. Ahora mismo comparto 1,6 Gb en la carpeta Incoming y estoy bajando 53 archivos. La mayoria de ellos son de unos 300 Mb (cosas sin copyright). Supongo que debo poner menos archivos en mi tabla de download para que no pete. ¿No es asi? Dado que no quiero cancelarlos ya que de casi todos tengo al menos unos 50 Mb ¿que es lo que debería hacer ? ¿pausar el download de unos 30 para que no se cuelgue?.
Espero explicarme mejor.
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Me desaparece el contenido de la ventana.
« Reply #5 on: June 11, 2004, 12:29:31 AM »

Se te entiende perfectamente. Bueno, que voy a decir... se cuelga ;-)
El problema es que se trata de una versión RC. Tiene mil cosas (o más) que la última versión estable no tiene, pero se cuegla bastante más. 50 downloads están bien. He visto gente con 300 e incluso más, sin problemas.
Sin embargo, deberías mirar que versión de wx tienes instalada (debe ser la 2.4.2) y a que versión de GTK está wx enlazado (debería ser la 1.2).
Ya dirás algo. También informa de si has instalado de rpms, debs, código fuente, que distro... y cuanto rato te dura el aMule antes de colgarse.
Un saludo!
Logged

SAC82

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: Me desaparece el contenido de la ventana.
« Reply #6 on: June 11, 2004, 12:56:23 AM »

Hola,
Yo amule lo instale a traves de una aplicacion gráfica que tiene Knoppix que se llama Kpackage.
Soy un bastante novato y desconocía el uso e incluso existencia de wx. Lo que tengo instalado en mi knopixx que contenga wx es:
 
bochs-wx versión 2.1.1-2

libwxbase2.4 versión 2.4.2.4

libwxgtk2.4 versión 2.4.2.4

Ahora mismo llevo 21 minutos y todavía no se ha colgado el burro.
Gracias por tu ayuda,
Sergio
Logged

SebaX

  • Forum/eMail Support Helper
  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 193
  • Las respuestas via e-Mail serán respondidas a la brevedad posible, tengan consideración que uno tambien tiene cosas que hacer, pero se hace lo posible por responder lo antes posible :D
    • http://www.sbmsbm.tk
Re: Me desaparece el contenido de la ventana.
« Reply #7 on: June 11, 2004, 07:46:34 AM »

Hola, que tal?
jejejeje, sin siquiera pensarlo me diste una pista ;)(aunque no para solucionar el problema :(, pero si para que mires como funciona tu sistema:D algo es algo, al menos de cultura general)
- KPackage es un gestor de paquetes(estos son los archivos de instalación de cierto programa) de KDE, por ende, estas usando KDE y en KDE para saber si se te quedo pegado algun programa haces lo siguiente:(la verdad es que nunca he usado Knoppix de hecho el soporte lo doy solo para las plataformas listadas en la parte de la firma :()... pero de todas formas DEBERIA SER:
Click en icono KDE(o en el logo de Knoppix, o en el primer icono abajo a la izquierda, o mejor en lo que sería el menu de inicio de wintendo), luego haces click en sistema, luego a monitor y por último le haces click a "Guardián del sistema de KDE", luego te metes a "Tabla de Procesos" y ahí estarán todos los programas listados, buscas aMule y ves que estado tiene en la tabla estado. Si dice Atascado, No responde, o algo como que se lea NO esta funcionando, es por que se te pego(igual podrías decir acá que dice en el momento de tu problema).
- Te recomiendo que no bajes tantos archivos a la vez, por que son 20 y de 300MB o sea 6000MB 5.8GB aprox. en mi caso yo solo al bajar uno de 4.2GB con un PC similar al tuyo salvo que es Pentium III, mi pc colapsaba. Ademas he notado que en aMule, mientras más archivos bajar y mientras más grandes sean, mayor es la posibilidad de que se caiga, asi que prueba bajando de a pocos archivos, yo estoy muy seguro que el problema pasa por que son muchisimos archivos y muy grandes.

Chau, que estes bien, si tienes dudas solo hazlas saber :D... Si no te funcionan los trucos que te mencioné sigue informando, para descubrir que pasa, trataré de instalar Knoppix durante el fin de semana(aunque tal vez ya sea muy tarde para darte una solución).
Logged
Student of Computer Science Engineering.
Linux Development, GNU/GPL Development.
User of Linux  :  Debian, Slackware 9.0-10.0, SuSE 8.0->9.1, Red Hat 6.0 ->Fedora 1
User of xBSD  :  FreeBSD 4.8->5.1.2 and OpenBSD 3.4
User of SunOS : Solaris 9->10

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Me desaparece el contenido de la ventana.
« Reply #8 on: June 11, 2004, 05:44:09 PM »

Haz tb `locate wx_gtk` a ver a que version de GTK sale que está enlazado.
Un saludo
Logged

Danik

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Me desaparece el contenido de la ventana.
« Reply #9 on: June 11, 2004, 08:36:23 PM »

A mí me ocurre lo mismo pero con la versión 1.2.6. De vez en cuando (a veces aguanta bien varios días) la ventana del emule deja de "refrescar" y se ve todo gris o todo blanco.

Yo uso gentoo y wxWindows 2.4.2 compilado contra gtk 1.2.10.

Saludos
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Me desaparece el contenido de la ventana.
« Reply #10 on: June 12, 2004, 02:55:26 AM »

Dani, tu problema es un bug conocido en 1.2.6 corregido en las siguientes versoines inestables (a ver si utilizamos la funcion buscar del foro... :-/)
Chapuza para solucionarlo:
Preferencias -> Twaeks -> refreshtime -> realtime
Un saludo!
Logged

SAC82

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: Me desaparece el contenido de la ventana.
« Reply #11 on: June 12, 2004, 02:35:26 PM »

Hola,
Parece que el problema se ha solucionado. He actualida KDE a 3.2 y ahora llevo con amule toda la mañana descargando sin que se cuelgue. Sobre lo demás:
a) He instalado el guardian del sistema. Un paquete intersante  Sebax :-)    
b) Sobre la version de wx y a que gtk lo tengo enlazado. He ejecutado lo que me dijistes Jacobo y supongo que querra decir que tengo la verison wx 2.4 y esta enlaza a 1.1. Es asi?

sergio@sergio:~$ locate wx_gtk
/usr/lib/libwx_gtk-2.4.so.0
/usr/lib/libwx_gtk-2.4.so.0.1.1
/usr/lib/libwx_gtk_gl-2.4.so.0
/usr/lib/libwx_gtk_gl-2.4.so.0.1.1

Gracias por vuestra ayuda.
Sergio
Logged

Danik

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Me desaparece el contenido de la ventana.
« Reply #12 on: June 12, 2004, 06:23:31 PM »

Gracias, Jacobo. No utilicé la función buscar porque creía que se trataba del mismo problema que tenía SAC82. Que estáis a la que salta ;)

Saludos
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Me desaparece el contenido de la ventana.
« Reply #13 on: June 12, 2004, 06:39:08 PM »

enlazada a la 1.2 suopngo. El caso es que esta enlazada a GTK1 y eso es lo imporannte ;-)
Sí, too en orden. Suerte con las descargas ;-)
Un saludo!
Logged

SAC82

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: Me desaparece el contenido de la ventana.
« Reply #14 on: June 12, 2004, 07:58:22 PM »

Hola,
Pues se me ha bloqueado otra vez. Parece que tarda más tiempo pero se queda bloqueado como siempre. en una par de horas se me revienta. ¿Teneis alguna idea?. ¿Como puedo probar con menos archivos sin perder las descargas anteriores que tenía?.
Sergio
Logged
Pages: [1] 2